NX-OSv Build

see also:

http://www.firewall.cx/cisco-technical-knowledgebase/cisco-data-center/1208-nexus-vpc-configuration-design-operation-troubleshooting.html

Interfaces e1/7 are the keepalive links

interfaces e1/1-2 are the vpc peer-links


nxos1# sh vpc brie
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                     : 10
Peer status                       : peer adjacency formed ok
vPC keep-alive status             : peer is alive
Configuration consistency status  : success
Per-vlan consistency status       : success
Type-2 consistency status         : success
vPC role                          : primary
Number of vPCs configured         : 0
Peer Gateway                      : Disabled
Dual-active excluded VLANs        : -
Graceful Consistency Check        : Enabled
Auto-recovery status              : Disabled
Delay-restore status              : Timer is off.(timeout = 30s)
Delay-restore SVI status          : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router    : Disabled

vPC Peer-link status
---------------------------------------------------------------------
id    Port   Status Active vlans
--    ----   ------ -------------------------------------------------
1     Po10   up     1

nxos1#

nxos1# sh run int e1/7 | b ver
version 7.0(3)I7(2)

interface Ethernet1/7
  no switchport
  vrf member keepalive
  ip address 1.1.1.1/30
  no shutdown

nxos1#

nxos2# sh run int e1/7 | b ver
version 7.0(3)I7(2)

interface Ethernet1/7
  no switchport
  vrf member keepalive
  ip address 1.1.1.2/30
  no shutdown

nxos2#

below sw1; same for both switches except reverse peer keepalive 
   destination and source for sw2,  and priority on sw2 is 20 (choose)

vrf context keepalive

vpc domain 10
  role priority 10
  peer-keepalive destination 1.1.1.2 source 1.1.1.1 vrf keepalive

interface port-channel10
  switchport mode trunk
  spanning-tree port type network
  vpc peer-link

interface Ethernet1/1
  switchport mode trunk
  channel-group 10 mode active

interface Ethernet1/2
  switchport mode trunk
  channel-group 10 mode active

nxos1# ping 1.1.1.2 vrf keepalive
PING 1.1.1.2 (1.1.1.2): 56 data bytes
64 bytes from 1.1.1.2: icmp_seq=0 ttl=254 time=6.899 ms
64 bytes from 1.1.1.2: icmp_seq=1 ttl=254 time=5.165 ms
64 bytes from 1.1.1.2: icmp_seq=2 ttl=254 time=4.461 ms
64 bytes from 1.1.1.2: icmp_seq=3 ttl=254 time=11.518 ms
64 bytes from 1.1.1.2: icmp_seq=4 ttl=254 time=4.418 ms

--- 1.1.1.2 ping statistics ---
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min/avg/max = 4.418/6.492/11.518 ms
nxos1#