Juniper: IBGP/Static Route

set interfaces ge-0/0/0 mac 50:03:00:01:00:02
set interfaces ge-0/0/0 unit 0 family inet address 10.10.10.1/30
set interfaces lo0 unit 0 family inet address 1.1.1.1/32
set routing-options static route 2.2.2.2/32 next-hop 10.10.10.2
set routing-options router-id 1.1.1.1
set routing-options autonomous-system 64512
set protocols bgp export IBGP-EXPORT
set protocols bgp group IBGP type internal
set protocols bgp group IBGP local-address 1.1.1.1
set protocols bgp group IBGP neighbor 2.2.2.2
set protocols lldp interface all
set policy-options policy-statement IBGP-EXPORT term EXPORT-STATIC from protocol static
set policy-options policy-statement IBGP-EXPORT then accept


interfaces {
    ge-0/0/0 {
        mac 50:03:00:02:00:02;
        unit 0 {                        
            family inet {
                address 10.10.10.2/30;
            }
        }
    }
    ge-0/0/1 {
        mac 50:03:00:02:00:03;
        unit 0 {
            family inet {
                address 10.10.10.5/30;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 2.2.2.2/32;
            }
        }
    }
}
routing-options {
    static {                            
        route 1.1.1.1/32 next-hop 10.10.10.1;
        route 3.3.3.3/32 next-hop 10.10.10.6;
    }
    router-id 2.2.2.2;
    autonomous-system 64512;
}
protocols {
    bgp {
        group IBGP {
            type internal;
            local-address 2.2.2.2;
            export IBGP-EXPORT;
            neighbor 1.1.1.1;
            neighbor 3.3.3.3;
        }
    }
    lldp {
        interface all;
    }
}
policy-options {
    policy-statement IBGP-EXPORT {
        term EXPORT-STATIC {            
            from protocol static;
        }
        then accept;
    }
}
root@vMX-A> traceroute 3.3.3.3 
traceroute to 3.3.3.3 (3.3.3.3), 30 hops max, 40 byte packets
 1  10.10.10.2 (10.10.10.2)  24.503 ms  41.006 ms  2.184 ms
 2  3.3.3.3 (3.3.3.3)  13.260 ms  20.288 ms  4.066 ms

root@vMX-C# run show route | match BGP 
1.1.1.1/32         *[BGP/170] 00:58:29, localpref 100, from 2.2.2.2
                    [BGP/170] 00:58:29, localpref 100, from 2.2.2.2
10.10.10.0/30      *[BGP/170] 00:58:29, localpref 100, from 2.2.2.2
                    [BGP/170] 00:58:29, localpref 100, from 2.2.2.2