IRB (BVI)

This is a topic that was removed from R&S quite a while ago, but i found an interest for it recently.

simply:

make interfaces on R1 and R2 to connect via different vlan access ports to SW1 but using the same ip subnet

R1#sh run int e0/1 | be int
interface Ethernet0/1
ip address 192.168.1.1 255.255.255.0
end

R2#sh run int e0/2 | b int
interface Ethernet0/2
ip address 192.168.1.2 255.255.255.0
end

SW1#sh vlan brie | i 10|20
10 VLAN0010 active Et0/1
20 VLAN0020 active Et0/2

make a trunk to R3

SW1#sh int trunk

Port Mode Encapsulation Status Native vlan
Et0/3 on 802.1q trunking 1

Essentially we will turn the router into a bridge, or SVI using IRB

turn on bridge irb in R3 config mode

make dot1q interfaces on the router where it connects to the switch

R3#sh run int e0/3.10 | b int
interface Ethernet0/3.10
encapsulation dot1Q 10
bridge-group 1
end

note dot1q, bridge group and no ip address for the sub-interfaces

R3#sh run int e0/3.20 | b int
interface Ethernet0/3.20
encapsulation dot1Q 20
bridge-group 1
end

enable protocol support for bridging and ip in config mode:

R3#sh run | i bridge 1
bridge 1 protocol ieee
bridge 1 route ip

apply an ip address in the same subnet as the other routers with a BVI (bridge virtual interface)

R3#sh run int bvi 1 | b int
interface BVI1
ip address 192.168.1.3 255.255.255.0
end

now the router is a bridge

R1#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
R1#ping 192.168.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
R1#